vMotion Interface Is Not Configured On Source And/Or Destination Error on Nexus 1000

When you received the following error: The vMotion interface is not configured (or is misconfigured) on the Source and/or Destination host, you need to enable vMotion interface.

Click on your host -> Configuration -> Hardware -> Networking ->Virtual Switch

Select the vSwitch for your Management traffic (in this case is vSwtich0) -> click on Properties

View all Port properties and find the one who has vMotion and check the status.

If vMotion is set to disabled, click on Edit

Select the check box to enable vMotion

Move the desired VM to different hypervisor.

Enable Wireless AP with Radius Authentication

Prerequisite: must enable your Radius method for you authentication: https://iiwanblog.wordpress.com/2013/04/10/enable-radius-authentication-and-accounting-for-cisco-router/

Router Config:

———————————————————————————————————————————————————

hostname iwan-router

 

// I’ll setup my SSID as iwan-ssid

dot11 syslog

dot11 ssid iwan-ssid

authentication open eap iwan-radius-method

authentication key-management wpa version 2

aacounting iwan-radius-method

guest–mode

 

// Enabling IRB: allowing bridging of traffic

bridge irb

 

// The wireless config (channel 6, bridge group 1)

interface Dot11Radio0

no ip address

no ip route-cache

 

encryption mode ciphers aes-ccm

 

ssid iwan-ssid

 

antenna gain 0

channel 6

station-role root

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

 

// Associate my bridge-group into one of actual interface

interface Fa0

no ip address

no ip route-cache

no keepalive

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

 

// The interface for my wireless (address: 172.16.10.1 /24)

interface BVI1

ip address 172.16.10.1 255.255.255.0

no ip route-cache

 

// Allowing to route mode

bridge 1 route ip

Enable Radius Authentication and Accounting for Cisco Router

Must enable Radius on your server and get the key and port number (in this case is 1812 and 1813, and key is iwanradiuskey)

Router Config:

———————————————————————————————————————————————————

hostname iwan-router

aaa new-model

// My Radius server IP address is 172.16.1.1 (which I will group it on my Cisco router as iwan-radius-server)

aaa group server radius iwan-radius-server

server 172.16.1.1 auth-port 1812 acct-port 1813

// I’ll use my Radius server for my authentication and accounting methods (I’ll called it iwan-radius-method) and use local mode for my authorization

aaa authentication login iwan-radius-method group iwan-radius-server

aaa authorization exec default local

aaa accounting network iwan-radius-method start-stop group iwan-radius-server

// I’ll instruct it to not bother of trying to resolve name into IP address and my domain name is iwan.com

no ip domain lookup

ip domain name iwan.com

// I specify which interface (in this case is my wireless interface – BVI1) to use Radius, and I’ll also use NAS-Identifier on Radius

ip radius source-interface BVI1

radius-server attribute 32 include-in-access-req format %h

radius-server host 172.16.1.1 auth-port 1812 acct-port 1813 key 0 iwanradiuskey

radius-server vsa send accounting

Allowing Incoming Connection TCP Port 29146 On Public IP Address on Cisco router

This list is to allow incoming connection from outside/public to connect to the public-facing IP address (Ex: 1.1.1.1 on Fa0 interface) on Cisco router for specific TCP port: 29146 that will be translated to inside IP address (one public-facing server that has internal IP address of: 192.168.1.1 with the same port of 29146 that connect to the same Cisco router of Fa1 interface):

1. Create ACL (let’s called it ALLOWCONNECTION):

access-list ALLOWCONNECTION permit ip host 192.168.1.1 any

2. Create a route-map (let’s call it MAP):

route-map MAP permit 10

match ip address ALLOWCONNECTION

3. Create IP Nat:

ip nat inside source static tcp 192.168.1.1 29146 1.1.1.1 29146 route-map MAP

4. Specify NAT direction (incoming on Fa1 and outgoing on Fa0):

interface Fa0

ip nat outside

interface Fa1

ip nat inside

Installing/Removing Zebra Printer

Make sure you have installed the appropriate driver for the connection: Prolific (if you are using USB dongle to Serial port), or other driver.

Download Zebra Setup Utility tool from zebra.com

Unplug the zebra printer connection to your machine, then install and run zebra setup utility

If this is a brand new zebra printer installation, select install new printer, select appropriate port.

If is to remove the printer, click refresh printer,  select the zebra printer, and click on remove printer.